Site displaying in Russian


#1

Is it just me or does anyone else have the site topics text etc displaying in Russian?

If it is just me can someone direct me on how to find the English button lol


#2

I’ve been looking around some settings/preferences and can’t see anything about languages.
I would say maybe try with a different browser or even your phone maybe you have a preferred language somewhere.


#4

It might be a bug!

Your preferences were set to “default” which should be English, but I updated it back to English manually and then logged in as you and it looks ok to me now. (Accidentally posted as you here too, oops). Let me know if it’s still happening!


#5

Yep seems to have done the trick! I’ve added a image so you can see the issue I was having